Database Failure

Incident Report for Meadow

Resolved

We have fixed the issue causing slowdowns and will continue to monitor performance. We apologize about any issues you may have had.
Posted Jan 09, 2018 - 22:02 PST

Investigating

We are currently investigating an issue with our database causing intermittent downtime.
Posted Jan 09, 2018 - 21:23 PST